Ohne Risiko hosten
1 Monat Vertraglaufzeit
03834 5139-52
Wir beraten Sie gerne.
support@estugo.de
Auch gerne per E-Mail.

PrestaShop Sicherheitsproblem im Passwort-Generierungsalgorithmus

Als erstes legen Sie bitte eine Datensicherung an. Das Sicherheitsproblem betrifft alle Versionen von PrestaShop außer Version 1.6.1.0 und PrestaShop Cloud. Es betrifft somit die Zweige 1.4.x, 1.5.x und 1.6.x bis 1.6.0.14. Sie können die derzeitige Version Ihres Shops unter „Erweiterte Einstellungen -> Systemeinstellungen -> Presta-Shop-Version“ aulesen. Sollte Ihre Version […]

PrestaShop Sicherheitsproblem im Passwort-Generierungsalgorithmus

Als erstes legen Sie bitte eine Datensicherung an.

Das Sicherheitsproblem betrifft alle Versionen von PrestaShop außer Version 1.6.1.0 und PrestaShop Cloud. Es betrifft somit die Zweige 1.4.x, 1.5.x und 1.6.x bis 1.6.0.14. Sie können die derzeitige Version Ihres Shops unter „Erweiterte Einstellungen -> Systemeinstellungen -> Presta-Shop-Version“ aulesen.

prestashop-version-auslesen

Sollte Ihre Version vom Patch abgedeckt sein, klicken Sie bitte als nächstes auf „Module“. In der Suchleiste geben Sie bitte „security“ ein, dass Modul wird nun rechts angezeigt und kann mit klick auf „installieren“ installiert werden.

Sollten Sie einen Fehler wie folgt erhalten: „The security update could not be applied to your shop. The module cannot execute the patch on your server configuration. Please check the details below for each update to see how you can implement the patch on your shop.“ kann es mehrere Ursache haben.

  • Das Linuxpaket „patch“ steht nicht zur Verfügung
  • safe_mode für PHP ist aktiviert
  • exec für PHP wurde deaktiviert
  • Die Version Ihres Shops wird nicht unterstützt

Bitte beachten Sie, dass wenn das Modul bereits installiert wurde, es sich nicht nochmals installieren lässt. Es wird der selbe oben genannten Fehler angezeigt, obwohl alle Einstellungen bereits gegeben waren. Vermutlich handelt es sich um einen Fehler im Modul.

Sie können den Patch auch für folgende Versionen manuell über den FTP-Server installieren, hierzu müssen Sie nur wenige Dateien austauschen:

1.6.0.14
1.5.6.2
1.4.11.0

Wenn Sie Fragen oder gar Probleme zu diesem Sicherheitsupdate oder zur Installation haben, können Sie gerne unsere Service-Partner kontaktieren oder im Forum um Rat fragen.